Build 268 (Version 2.8 RC6)

Where the test pilots meet and discuss their flight day. Now open to the public ;-)

Moderators: blackbird1955, frankynov, desktopsimmer, Elefant

Build 268 (Version 2.8 RC6)

UNREAD_POSTby Sascha » Wed Apr 03, 2013 11:08 am

When I tried to upload build 266 to Apple yesterday it failed because I was running an old version of Xcode.
(I have to use the old version to be able to test it on my first generation iPod touch)

I don’t think there’s anything wrong with build 266 (I’m pretty sure that I compiled it with the latest version of Xcode).
Nevertheless, I compiled it again (the compilation procedure got quite complex too: Since Apple dropped support for ARMv6 based devices in Xcode 4.5, I have to compile the ARMv6 code in Xcode 4.4 first, and then use a custom script in Xcode 4.6 to compile for ARMv7 and ARMv7s and include the previously built ARMv6 version).

I’ll upload build 268 in a minute. It should be identical to build 266 (I did not change anything in the code). I just did not want to risk anything with the release build.
Sascha
Site Admin
 
Posts: 3232
Joined: Wed Jan 27, 2010 12:43 pm

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby Sascha » Thu Apr 04, 2013 4:56 pm

I’ve submitted it to Apple, but please continue to test build 268. If we find anything serious, I can still reject it.
So far I’ve found two minor problems:
* On slower devices (an iPhone 3GS in this case), the record dialog stays visible for a second or two after recording has started. It scrolls down, but somehow is still visible in the lower edge of the screen (which is usually black due to the letterboxing). It disappears after about two seconds, but during that two seconds, the stop button does not respond.
* On the iPad I’ve seen the following: After stopping the video recording, the screen went black. Tapping the screen once solved the issue (it was back in the replay and rendered the frame normally).
Sascha
Site Admin
 
Posts: 3232
Joined: Wed Jan 27, 2010 12:43 pm

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby Elefant » Thu Apr 04, 2013 6:05 pm

On the iPad 3, I was able to reproduce Sascha's bug with the black screen, two times in a row. I began with a low def recording, then I stopped it. I then closed the recording dialogue box with the cancel button and then appeared the black screen, I touched the screen to get the situation back to normal.

Another one that may be a bug, the radio volume was inopperative. First time I notice that. :?: :?:

image.jpg
Elefant
 
Posts: 720
Joined: Wed Mar 02, 2011 10:51 pm
Location: Paris, France

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby desktopsimmer » Thu Apr 04, 2013 8:37 pm

Interesting Feature: if you land without HUD, on the replay you can turn it back on and see how good or bad you have done. You can also record it (with or without HUD).
desktopsimmer
 
Posts: 1599
Joined: Fri Apr 02, 2010 12:17 pm
Location: UK

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby Sascha » Thu Apr 04, 2013 10:36 pm

I’ll look into the black screen, but since it goes away once you tap on the screen, it don’t think it’s a big deal.

Radio is disabled if it’s not been at least a safe landing.

Desktopsimmer:
Nice find. But you can e.g. turn the HUD on or off during a flight too. These things are not recorded, so in a replay, the HUD is either on or off (depending on whether you turned it on or off before starting the replay). I didn’t think about that when implementing the recording feature, but I don’t think its a problem.
What do you think?
Sascha
Site Admin
 
Posts: 3232
Joined: Wed Jan 27, 2010 12:43 pm

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby desktopsimmer » Thu Apr 04, 2013 10:43 pm

Keep it as is :) it nice to see in the replay how far I was off the glide scope. I'll test tomorrow to see if the achievement is effected.

BTW this is how the no HUD landing looked. Surprised I didn't completely washed out. The end score was 515,000 and the approach was flown a little too high.

desktopsimmer
 
Posts: 1599
Joined: Fri Apr 02, 2010 12:17 pm
Location: UK

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby Sascha » Fri Apr 05, 2013 2:33 pm

PAPIs and the ball/bar ;)

Another thing I noticed is that the video quality in the low setting is quite poor—there are visible artifacts when there’s a lot of motion. I guess it’s OK for this version (it says “low quality” after all and is intended to safe space and bandwidth).
In the next version I’ll probably add another, even lower resolution (480x270), call the current “low” setting “medium” with a higher bitrate.
Sascha
Site Admin
 
Posts: 3232
Joined: Wed Jan 27, 2010 12:43 pm

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby desktopsimmer » Sat Apr 06, 2013 8:03 pm

Minor of minorest bugs:

If you scrub to the end of a replay and repeatly hit play (even though you are at the end) it seems to advance a couple of frames. IMHO it's nothing to worry about in this release
desktopsimmer
 
Posts: 1599
Joined: Fri Apr 02, 2010 12:17 pm
Location: UK

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby desktopsimmer » Sun Apr 07, 2013 8:11 am

2.8 is now released. :)
desktopsimmer
 
Posts: 1599
Joined: Fri Apr 02, 2010 12:17 pm
Location: UK

Re: Build 268 (Version 2.8 RC6)

UNREAD_POSTby Sascha » Sun Apr 07, 2013 10:47 am

So far the update seems to work fine, I’ve got one customer who’s experiencing problems though.

He says the update process hang (reading “installing…” under the icon). He can’t open the app, and not even delete it (it’s greyed out).
He already tried re-booting the device, and he’s got plenty of free space.

Has anybody ever seen something like this or has got an idea how to resolve it?
Sascha
Site Admin
 
Posts: 3232
Joined: Wed Jan 27, 2010 12:43 pm

Next

Return to Pancho's Fly-Inn

Who is online

Users browsing this forum: No registered users and 6 guests

cron