Sound disappeared on Android version.

Need help with F-SIM Space Shuttle? Post your questions here.

Moderators: blackbird1955, frankynov, desktopsimmer, Elefant

Sound disappeared on Android version.

UNREAD_POSTby tzj » Sat Jun 08, 2013 9:41 pm

Hello, I am new to the forum. :)

I have been playing this game/simulator on my iPod touch since forever. Recently I found out that there finally is a version for android too.

Yesterday I bought it for my Galaxy Nexus and played for HOURS. Today, when I started the app, the sound was gone. No sound att all except for the sound in the menues.

I play with headphones connected, and other apps works just fine. What has happened?

Thank you for a wonderful simulator, I have enjoyed it for a long time now. :)
tzj
 
Posts: 4
Joined: Sat Jun 08, 2013 9:36 pm

Re: Sound disappeared on Android version.

UNREAD_POSTby frankynov » Sat Jun 08, 2013 9:55 pm

Hey, and welcome to the forum ! :)

First thing to check of course is the volume in the menus. I think the value is different from the speaker configuration when the headphones are connected. If I'm right, there are 3 volumes manages by Android : Ringtones, media and alarms.
Does the sound play when you don't connect them ?

If everything seems normal in the settings, then I'm sure Tee will be able to answer you better than me :)
Best,

François
frankynov
 
Posts: 845
Joined: Sun Feb 14, 2010 4:48 pm
Location: Namur, Belgium

Re: Sound disappeared on Android version.

UNREAD_POSTby tzj » Sun Jun 09, 2013 9:45 am

frankynov wrote:Hey, and welcome to the forum ! :)

First thing to check of course is the volume in the menus. I think the value is different from the speaker configuration when the headphones are connected. If I'm right, there are 3 volumes manages by Android : Ringtones, media and alarms.
Does the sound play when you don't connect them ?

If everything seems normal in the settings, then I'm sure Tee will be able to answer you better than me :)
Best,

François


Hello and thanks for the welcome. :)

I found out what the problem was. I usually have my Nexus on mute. I use the phones ledlight together with the app lightflow instead. So I have no sounds on for incoming calls, messages, emails, notifications and so on.

When the phone is on mute, I can still play music and other games with the sound from the specific app on. Both via the built in speaker and via headphones.
However, F-Sim does not enable sound at all if the phone is muted, but the app sound turned on. I have to disable the silent mode on the phone to be able to get sound in the simulator.

Rather weird, since no other app behaves that way. It is not a problem though, just glad I found out what the solution was!
tzj
 
Posts: 4
Joined: Sat Jun 08, 2013 9:36 pm

Re: Sound disappeared on Android version.

UNREAD_POSTby Sascha » Sun Jun 09, 2013 11:23 am

Hi tzj,

thanks for your feedback and welcome to the forum!

Rather weird, since no other app behaves that way.


Well, it should certainly not mute the headphones—perhaps Tee can look into this. Muting the speakers makes perfect sense to me though, but that’s taken directly from how the iPhone behaves:

* If you set it to mute, it will not make any unwanted sounds (incoming calls or messages, keyboard clicks, etc.). This is what you want in a theatre, a meeting, at school :)
* If you explicitly tell the device to play music or video, you don’t have to un-mute it though. So music or video apps usually ignore the mute switch setting
* Games and other apps on the other hand stay muted.

This makes perfect sense to me, is how all iPhone apps behave, and what iOS users expect. It’s also kind of enforced on iOS by setting the correct audio category for an app.

I don’t know what kind of settings there are on Android, and I also don’t know how Android users expect these settings to influence the behavior of games and other apps. Are there any kind of guidelines, or is this one of the things where Android is “open”? ;)
Sascha
Site Admin
 
Posts: 3232
Joined: Wed Jan 27, 2010 12:43 pm

Re: Sound disappeared on Android version.

UNREAD_POSTby tzj » Sun Jun 09, 2013 11:45 am

Well, I am not very familiar with how android works. Got the phone cheap from a friend last year. It has some features I like though.

At home I use Mac and a PC, but my experience with games on my Android device is quiet limited. On my old iPod Touch, I never had any problems.
If this "problem" is isolated to Android? Have no clue. If I have to guess, it is.

iOS is a very stable OS in my opinion, more stable than Android, but since I figured out what caused the soundissue, I won´t yak any further about different OS:es. 8-)

I just hope my posts can help anybody who might experience this "glitch". In my opinion, it is a bit unlogical (word?).

Well, I don´t have time to sit here anymore. F-Sim Shuttle needs to be played. :mrgreen:
tzj
 
Posts: 4
Joined: Sat Jun 08, 2013 9:36 pm

Re: Sound disappeared on Android version.

UNREAD_POSTby tee » Mon Jun 10, 2013 7:01 pm

Hi tzj,

On Android there are several sound modes (sound mode, ringer mode, vibrate mode, silent mode, normal mode etc...) and it's up to the application how to beheave. I've changed this configuration in an update because some people complained about having sound in vibrate mode, but since that update there are more people complaining about having no sound...
I'll revert this setting with the next update and have a look what's the common practise amongst apps and definitely add an option to choose in the audio settings...
tee
Site Admin
 
Posts: 238
Joined: Tue Jun 12, 2012 4:48 pm

Re: Sound disappeared on Android version.

UNREAD_POSTby tzj » Fri Jun 14, 2013 8:01 pm

For me personally, the problem is gone. I drove a screwdriver through my Nexus and bought an iPhone 5 instead. No problems anymore.
Thanks for all the help though, hope someone can use the information.
Attachments
rsz_dsc_0199.jpg
tzj
 
Posts: 4
Joined: Sat Jun 08, 2013 9:36 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron